ISSUE: PeppermintOS 10 Respin and NVidia 8800M GTS NVidia 340.108 (Solved)

Home Forums Operating Systems Linux PeppermintOS ISSUE: PeppermintOS 10 Respin and NVidia 8800M GTS NVidia 340.108 (Solved)

Viewing 1 post (of 1 total)
  • Author
  • #671

    After a long time of trying things I have found all over the internet about installing nvidia drivers, I finally stumbled across a site that had the answer. It seems that Ubuntu 18.04 does not install the correct headers for the nVidia 340.108 drivers which caused them not to install correctly.

    Install the Correct Headers:

    sudo apt install linux-image-4.15.0-112-generic linux-headers-4.15.0-112-generic
    sudo reboot

    Install Drivers:

    sudo add-apt-repository ppa:graphics-drivers/ppa
    sudo apt-get update

    CTL+ALT F1 to get into terminal

    sudo systemctl stop lightdm
    ubuntu-drivers devices
    sudo ubuntu-drivers autoinstall
    sudo apt-get update
    sudo nvidia-xconfig
    sudo reboot

    *NOTE: Your first reboot may be to big fonts and flickering. If so, just do a reboot.

    To check your system after reboot:
    sudo lshw -numeric -C display or sudo lspci -vnn | grep VGA


    Also, I noticed that if I use “Adapative” or “Auto” with the PowerMizer and it drops to the 275/602/550 settings, the display will go black and you have to reboot to get it back. I just set the PowerMizer to “Prefer Maximum Performance” to keep it at the 500/1598/1250 settings.

    PCNetSpec has a good method on having the PowerMizer set to “Prefer Maximum Performance” each time you start.

    Of course the PCNetSpec did not seem to automatically work for me, so I tried other things and came up with this that works… Settings > Default Applications on LXDE > Autostart and then add the following under “Manual autostarted applications”
    nvidia-settings -a [gpu:0]/GpuPowerMizerMode=1


    System:    Host: P6860FX Kernel: 5.4.0-42-generic x86_64 bits: 64 gcc: 7.5.0
               Desktop: N/A Distro: Peppermint Ten
    Machine:   Device: laptop System: Gateway product: P-6860FX v: 1234567 serial: N/A
               Mobo: Gateway model: P-6860FX v: 1234567 serial: N/A
               BIOS: Phoenix v: R01-A1P (94.29.00) date: 03/10/2008
    Battery    BAT0: charge: 63.6 Wh 100.0% condition: 63.6/73.3 Wh (87%)
               model: SMP-SDI SAPSSEET status: Full
               hidpp__0: charge: 85% condition: NA/NA Wh
               model: Logitech M570 status: Discharging
    CPU:       Dual core Intel Core2 Duo T9300 (-MCP-)
               arch: Penryn rev.6 cache: 6144 KB
               flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 9974
               clock speeds: max: 2501 MHz 1: 1697 MHz 2: 1982 MHz
    Graphics:  Card: NVIDIA G92M [GeForce 8800M GTS] bus-ID: 01:00.0
               Display Server: x11 (X.Org 1.20.8 ) driver: nvidia
               Resolution: [email protected]
               OpenGL: renderer: GeForce 8800M GTS/PCIe/SSE2
               version: 3.3.0 NVIDIA 340.108 Direct Render: Yes
    Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
               driver: snd_hda_intel bus-ID: 00:1b.0
               Sound: Advanced Linux Sound Architecture v: k5.4.0-42-generic
    Network:   Card-1: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
               driver: iwl4965 v: in-tree: bus-ID: 02:00.0
               IF: wlp2s0 state: up mac: <filter>
               Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
               driver: r8169 port: 4000 bus-ID: 04:00.0
               IF: enp4s0 state: down mac: <filter>
    Drives:    HDD Total Size: 878.2GB (6.7% used)
               ID-1: /dev/sdb model: ST750LX003 size: 750.2GB
               ID-2: /dev/sda model: SPCC_Solid_State size: 128.0GB
    Partition: ID-1: / size: 39G used: 8.9G (25%) fs: ext4 dev: /dev/sda5
    RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
    Sensors:   System Temperatures: cpu: 54.0C mobo: N/A gpu: 0.0:61C
               Fan Speeds (in rpm): cpu: N/A
    Repos:     Active apt sources in file: /etc/apt/sources.list
               deb bionic main restricted
               deb bionic-updates main restricted
               deb bionic universe
               deb bionic-updates universe
               deb bionic multiverse
               deb bionic-updates multiverse
               deb bionic-backports main restricted universe multiverse
               deb bionic-security main restricted
               deb bionic-security universe
               deb bionic-security multiverse
               Active apt sources in file: /etc/apt/sources.list.d/graphics-drivers-ubuntu-ppa-bionic.list
               deb bionic main
               Active apt sources in file: /etc/apt/sources.list.d/peppermint.list
               deb bionic main
               deb bionic main
    Info:      Processes: 202 Uptime: 31 min Memory: 1217.2/3935.1MB
               Init: systemd runlevel: 5 Gcc sys: 7.5.0
               Client: Shell (bash 4.4.201) inxi: 2.3.56
    • This topic was modified 9 months, 2 weeks ago by Voodoo.
    • This topic was modified 7 months ago by Voodoo.
    • This topic was modified 7 months ago by Voodoo.
    • This topic was modified 7 months ago by Voodoo.
    • This topic was modified 6 months, 4 weeks ago by Voodoo.
    • This topic was modified 6 months, 3 weeks ago by Voodoo.
Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.
Skip to toolbar