Reply To: DCS Updater

Home Forums Gaming FlightSims DCS World DCS World (General) DCS Updater Reply To: DCS Updater

#824
Voodoo
Keymaster

The Current 1.2 Legacy Build Version is: 1.2.16.43180
The Current 1.5 Legacy Build Version is: 1.5.8.13716
The Current 2.0 Alpha Legacy Build Version is: 2.2.0.12843

PLEASE NOTE THE UPDATED SYSTEM REQUIREMENTS FOR DCS 1.5 / 2.0 BEFORE UPDATING FROM 1.2.x

Minimum system requirements:
OS 64-bit Windows 7/8/10; DirectX11; CPU: Core i3; RAM: 8 GB; Free hard disk space: 30 GB; Discrete video card: 2 GB RAM (AMD, NVIDIA);
Requires internet activation.

Recommended system requirements:
OS 64-bit Windows 7/8/10; DirectX11; CPU: Core i5+; RAM: 16GB; Hard disk space: 30 GB; Video: NVIDIA GeForce GTX780 / ATI R9 290 DirectX11 or better; Joystick;
Requires internet activation.
*Note, Recommended System does not mean it can run DCS World w/ Max Graphics Settings.