ISSUE: R9 280X and resolutions above 1080p 60Hz (Solved)

Home Forums Operating Systems Linux PeppermintOS ISSUE: R9 280X and resolutions above 1080p 60Hz (Solved)

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #728
    Voodoo
    Keymaster

    EDITED FOR EASE OF UNDERSTANDING:

    Original problem: “No Signal” on a monitor that defaults to a resolution higher than 1080p 60Hz

    I am using the Sapphire Dual-X AMD R9 280X on a workstation that had the monitor upgraded from a 1080p 60Hz to a 3440×1440 100Hz monitor. Anytime you tried normal booting, just after Grub, the monitor would turn black and output “No Signal”.

    There are numerous locations that say the Linux Driver for the AMD R9 280X cannot do resolutions higher than 1920×1080 60Hz. However, I have found a few locations which talked about some workarounds that I am going to try.

    ==================================
    Option 1: Set Grub to default to 1920×1080 60Hz

    sudo xed /etc/default/grub

    GRUB_GFXMODE=1920x1080
    GRUB_GFXPAYLOAD_LINUX=keep

    sudo update-grub
    REF: https://forum.peppermintos.com/index.php/topic,8524.msg87561.html#msg87561

    This one seems to boot into 1920×1080 60Hz after you login. You still get “No Display” after booting to Grub in normal mode and the PeppermintOS login screen resolution seems to be 3440×1440. I am able to NoMachine into it and login. So, now I am working toward getting the login screen resolution and refresh rate set. The Autologin workaround is good, but you also have to disable screen timeout. Otherwise, it will timeout and go to that login screen that you have to remote into just to login and get your physical display back.

    Until I get this figured out, I am just using AutoLogin.
    Menu > System > Login Window
    Users Tab and set the user for Automatic login
    Reboot and I am operational.

    Login Screen Resolution fix for above.
    Get your mode. Since I wanted 1920×1080 mode, I typed in the following:
    cvt 1920 1080

    I got the output of

    # 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
    Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

    I then added this mode to my system

    xrandr --newmode 1920x1080_60.00  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    xrandr --addmode HDMI-A-0 1920x1080_60.00

    Removed the Auto login and reboot. SUCCESS!
    https://forum.peppermintos.com/index.php/topic,9564.0.html
    https://forum.peppermintos.com/index.php/topic,8325.msg85369.html#msg85369

    ==================================
    Option 2: Use the command at startup using Startup Applications

    xrandr -s 1920x1080 -r 60
    I am using Option 1 with Autologin for now. I did not get too far on this one as I did not find out how to run this command after Grub and prior to Login screen.
    REF: https://askubuntu.com/questions/59621/how-to-change-the-monitors-refresh-rate

    ==================================
    Option 3: Set the option “IgnoreEDIDChecksum” for the display

    I didn’t even get into even trying or testing this yet as I would like to be able to connect different monitors later on.
    REF: https://askubuntu.com/questions/834695/what-is-the-correct-way-to-force-a-permanent-monitor-resolution-change
    More Detail REF: https://askubuntu.com/questions/689030/second-monitor-has-low-resolution/689046

    ==================================
    Thanks for the help: alynur, murraymint

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.